Firmware

Warning: Radios may be damaged if proper procedure is not followed when updating firmware. Ensure all cables are secure and power supply is reliable. SATEL USA’s service department offers a firmware update service upon request.

Some radios may require earlier versions of firmware for compatibility with certain GPS/GNSS/positioning systems. If you have a radio controlled by a 3rd-party device, contact the vendor or your local dealer to ensure compatibility before attempting to change firmware.

All files are provided as .zip files and must be unzipped before flashing to radios.

Please contact us if you have any questions about updating firmware.


Enclosed Radios

SATELLINE 3AS and 3AS Epic

note: this firmware is for 3AS models manufactured in 2004 and later. Older models require different firmware.

3AS and 3AS Epic firmware version 3.63

SATELLINE 3AS NMS (UHF)

3AS NMS UHF firmware version 4.0.15.2

SATELLINE 3AS VHF

3AS VHF firmware version 4.0.15.2

SATELLINE EASy & Compact-Proof

SATELLINE EASy firmware version 3.63

SATELLINE EASy SURV firmware version 3.63 (surveyor firmware)

SATELLINE EASy CRYPT firmware version 3.63 (CRYPT-hardware variant only)

SATELLINE EASy SURV CRYPT firmware version 3.63 (surveyor firmware, CRYPT-hardware variant only)

SATELLINE EASy Pro 35W

SATELLINE EASy Pro 35W firmware version 3.63

SATELLINE EASy Pro 35W SURV firmware version 3.63 (surveyor firmware)

SATELLINE EASy Pro 35W CRYPT firmware version 3.63 (CRYPT-hardware variant only)

SATELLINE EASy Pro 35W SURV CRYPT firmware version 3.63 (surveyor firmware, CRYPT-hardware variant only)


Modules

SATELLINE M3-TR1

SATELLINE M3-TR1 firmware version 3.63

SATELLINE M3-TR3, M3-TR4, M3-R4

SATELLINE M3-TR3/TR4/R4 firmware version 2.3.2.17

SATELLINE M3-R3

SATELLINE M3-R3 firmware version 1.0.9.3


If you need an earlier version of firmware, or don’t see your radio listed here, please contact us.